Чат  ::   FAQ  ::   Поиск  ::   Регистрация  ::   Вход

После обновления freepbx 13 ошибка less в веб интерфейсе

WEB GUI и не только WEB

Модераторы: stas2k, april22

После обновления freepbx 13 ошибка less в веб интерфейсе

Сообщение LostAlly » 16 авг 2016, 19:04

Здравствуйте.
Сервер на debian 8.5
Asterisk 11 (установка из исходников)
Freepbx 13 (установка, между версиями не обновлял)
php - PHP 5.6.24-0+deb8u1

Пробовал удалять все модули, ошибка не уходит. Пробовал обновлять core, framework и все модули через консоль, обновляется без ошибок.

При входе в вебинтерфейс Выдается ошибка парсера less -
ParseError: Unexpected input in variables.less on line 74, column 1 72| 73| /* OLD */ 74| @chosen-sprite:.......

Не могу понять откуда растут ноги у этой ошибки, вручную ничего во freepbx не правил, asterisk работает нормально.

P.S. Не предлагайте избавится от freepbx так как на нем завязан vTiger. (запись-прослушивание звонков через коннектор)
Вложения
freepbx.png
LostAlly
 
Сообщений: 5
Зарегистрирован: 16 авг 2016, 18:42

Re: После обновления freepbx 13 ошибка less в веб интерфейсе

Сообщение gland » 16 авг 2016, 19:39

Что в httpd/error_log?
Не проблема ли в версиях php?
gland
 
Сообщений: 113
Зарегистрирован: 25 янв 2012, 11:07

Re: После обновления freepbx 13 ошибка less в веб интерфейсе

Сообщение LostAlly » 17 авг 2016, 12:32

К сожалению в логах пусто по поводу этой ошибки.
Эта же ошибка вываливается в консоль по fwconsole reload

[Показать] Спойлер:
root@pbx:/var/www/html/admin# fwconsole reload
Перезагрузка FreePBX
Произошла ошибка(-ки), ниже вывод из retrieve_conf
exit: 1
Less_Exception_Chunk: ParseError: Unexpected input in variables.less on line 74, column 1
72|
73| /** OLD **/
74| @chosen-sprite: "data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAADQAAAAlCAQAAACn+wJeAAAB4UlEQVRIx+2XsWtTURTGrwouLQQDwYLFzT3yJBDoYoVvySQoKFShSHe7qAgqiMn9rcUibnVwEARBl0AgUIh/QXBxFIpKJHAhUBz0HQcf4U0xtZwu+r3l8t4758fHPe/jvhBcRIUuWbFuMKAWnEB9jEQWAk0SRt8LtMo+RmKdhDGiHrzEChOMHGPsiAkhBDbIMXKu+2KaJUfZwcsXD4RJrJFKKHaw6fVmRnmNT5ydC9TDSDRCIGOMMfh9u8pegRmzNKP8NUZvzu+oR6NY19mddqVVgG7MKL5SvHPrcJu3g/F2xvMqowKUOHMYUJXhrAa8Ku1j90/dVFFXxaypoYFqfzFR80h9mZKyENRUkskrgrSqfZmS1pVkGskvG7SiiUy5TGP5RpA2lMuUyzeC1Cw5yrwxSWtKrij1ZEpqhKBMY5kGXqCKeioiSHXtain817+k9gLLLD887ozhLl8xjGG86onZxuIe99jCsHjTCRMvYvF9+1QIIcTz8RuTzmkfP0+jdaYJHW9jXPYBvYj5/ZNlf06HxvgEYzoC8Tk5l1xAnXP8IHVam8faC3GTn3x5cMJr6q5h0fjI5+L4suU24PFCfMkHhvExHQyL20eQEfERhsVncdEfdYfvGK2jcPUOK/+A/QJb5yp50uoC6QAAAABJRU5ErkJggg==";
75| @chosen-sprite-2x: "data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAADQAAAAlCAQAAACn+wJeAAAB4UlEQVRIx+2XsWtTURTGrwouLQQDwYLFzT3yJBDoYoVvySQoKFShSHe7qAgqiMn9rcUibnVwEARBl0AgUIh/QXBxFIpKJHAhUBz0HQcf4U0xtZwu+r3l8t4758fHPe/jvhBcRIUuWbFuMKAWnEB9jEQWAk0SRt8LtMo+RmKdhDGiHrzEChOMHGPsiAkhBDbIMXKu+2KaJUfZwcsXD4RJrJFKKHaw6fVmRnmNT5ydC9TDSDRCIGOMMfh9u8pegRmzNKP8NUZvzu+oR6NY19mddqVVgG7MKL5SvHPrcJu3g/F2xvMqowKUOHMYUJXhrAa8Ku1j90/dVFFXxaypoYFqfzFR80h9mZKyENRUkskrgrSqfZmS1pVkGskvG7SiiUy5TGP5RpA2lMuUyzeC1Cw5yrwxSWtKrij1ZEpqhKBMY5kGXqCKeioiSHXtain817+k9gLLLD887ozhLl8xjGG86onZxuIe99jCsHjTCRMvYvF9+1QIIcTz8RuTzmkfP0+jdaYJHW9jXPYBvYj5/ZNlf06HxvgEYzoC8Tk5l1xAnXP8IHVam8faC3GTn3x5cMJr6q5h0fjI5+L4suU24PFCfMkHhvExHQyL20eQEfERhsVncdEfdYfvGK2jcPUOK/+A/QJb5yp50uoC6QAAAABJRU5ErkJggg==";
76|
77| @button-has-error: #a94442; in file /var/www/html/admin/libraries/less/Less.php on line 510
Stack trace:
1. Less_Exception_Chunk->() /var/www/html/admin/libraries/less/Less.php:510
2. Less_Parser->GetRules() /var/www/html/admin/libraries/less/Less.php:328
3. Less_Parser->parseFile() /var/www/html/admin/libraries/less/Less.php:5875
4. Less_Tree_Import->ParseImport() /var/www/html/admin/libraries/less/Less.php:5803
5. Less_Tree_Import->compile() /var/www/html/admin/libraries/less/Less.php:6784
6. Less_Tree_Ruleset->evalImports() /var/www/html/admin/libraries/less/Less.php:6771
7. Less_Tree_Ruleset->PrepareRuleset() /var/www/html/admin/libraries/less/Less.php:6606
8. Less_Tree_Ruleset->compile() /var/www/html/admin/libraries/less/Less.php:186
9. Less_Parser->getCss() /var/www/html/admin/libraries/less/Cache.php:158
10. Less_Cache->Cache() /var/www/html/admin/libraries/less/Cache.php:94
11. Less_Cache->Get() /var/www/html/admin/libraries/BMO/Less.class.php:55
12. FreePBX\Less->generateMainStyles() /var/lib/asterisk/bin/retrieve_conf:558


fwconsole dbug по этому поводу говорит, что обнаружил ошибку retrive_conf
[Показать] Спойлер:
root@pbx:/var/www/html/admin# fwconsole dbug
+-----------------------+
| FreePBX Notifications |
+-----------------------+

Перезагрузка невозможна, скрипт retrieve_conf обнаружил ошибку: 1

Модуль: "FreePBX Framework", Файл: "/var/www/html/admin/libraries/Console/Debug.class.php изменён"

Neither app_meetme nor app_confbridge is configured in Asterisk, conferencing, paging and other functionality will not work properly

Unauthenticated calls to the OpenCNAM API will soon fail. You will need an Open CNAM account to continue using their API

You have selected an invalid language 'en_US' this has been automatically switched back to 'en_US' please resolve this in advanced settings [Nonexistent in Locale]

You are missing support for the following HTML5 codecs: mp3,m4a. To fully support HTML5 browser playback you will need to install programs that can not be distributed with FreePBX. If you'd like to install the binaries needed for these conversions click 'Resolve' in the lower left corner of this message. You can also safely ignore this message but browser playback might not work in your browser.

The FreePBX project is collecting anonymous browser statistics using google analytics. These are used to focus development efforts based on real user input. All information is anonymous. You can disable this in Advanced Settings with the Browser Stats setting.

The default bind ports for FreePBX have changed. Please keep this is mind while configuring your devices. You can change this in SIP Settings. CHAN_PJSIP is: 5061, CHAN_SIP is: 5060
OUT > ==> /var/log/asterisk/freepbx_dbug <==

==> /var/log/asterisk/apache_error_log <==

==> /var/log/asterisk/freepbx_security.log <==
[2016-04-21 14:23:00] Authentication failure for LostAlly from 192.168.1.250
[2016-04-25 15:18:17] Authentication failure for LostAlly from 192.168.1.250
[2016-05-05 15:03:27] Authentication failure for admin from 192.168.1.250
[2016-05-05 16:06:21] Authentication failure for LostAlly from 192.168.1.250
[2016-05-19 17:38:37] Authentication failure for LostAlly from 192.168.1.250
[2016-06-16 18:20:49] Authentication failure for LostAlly from 192.168.1.250
[2016-06-17 17:25:56] Authentication failure for LostAlly from 192.168.1.250

==> /var/log/asterisk/freepbx.log <==
[2016-Aug-17 01:01:18] [INFO] (bin/module_admin:633) - tts Not Installed (Available online: 13.0.8)
[2016-Aug-17 01:01:18] [INFO] (bin/module_admin:633) - ttsengines Not Installed (Available online: 13.0.6)
[2016-Aug-17 01:01:18] [INFO] (bin/module_admin:633) - ucp 13.0.38 Enabled and up to date
[2016-Aug-17 01:01:18] [INFO] (bin/module_admin:633) - userman 13.0.72 Enabled and up to date
[2016-Aug-17 01:01:18] [INFO] (bin/module_admin:633) - vmblast Not Installed (Available online: 13.0.8)
[2016-Aug-17 01:01:18] [INFO] (bin/module_admin:633) - voicemail 13.0.51 Enabled and up to date
[2016-Aug-17 01:01:18] [INFO] (bin/module_admin:633) - weakpasswords Not Installed (Available online: 13.0.1alpha1)
[2016-Aug-17 01:01:18] [INFO] (bin/module_admin:633) - webrtc Not Installed (Available online: 13.0.28)
[2016-Aug-17 01:01:18] [INFO] (bin/module_admin:633) - xmpp Not Installed (Available online: 13.0.14)
[2016-Aug-17 11:29:57] [CRITICAL] (BMO/Notifications.class.php:487) - [NOTIFICATION]-[freepbx]-[RCONFFAIL] - retrieve_conf не найден, конфигурация не применилась (Перезагрузка невозможна, скрипт retrieve_conf обнаружил ошибку: 1)
LostAlly
 
Сообщений: 5
Зарегистрирован: 16 авг 2016, 18:42

Re: После обновления freepbx 13 ошибка less в веб интерфейсе

Сообщение awsswa » 17 авг 2016, 12:55

http://asterisk-pbx.ru/wiki/troubleshoo ... eve_conf_1

Читайте ошибки

Neither app_meetme nor app_confbridge is configured in Asterisk, conferencing, paging and other functionality will not work properly

Unauthenticated calls to the OpenCNAM API will soon fail. You will need an Open CNAM account to continue using their API

You have selected an invalid language 'en_US' this has been automatically switched back to 'en_US' please resolve this in advanced settings [Nonexistent in Locale]
платный суппорт по мере возможностей
awsswa
 
Сообщений: 2350
Зарегистрирован: 09 июн 2012, 10:52
Откуда: Россия, Пермь skype: yarick_perm

Re: После обновления freepbx 13 ошибка less в веб интерфейсе

Сообщение LostAlly » 17 авг 2016, 19:40

Данные ошибки никак не связаны с неработающим web-интерфейсом pbx, они не блокирующие и были в то время, когда интерфейс работал.
LostAlly
 
Сообщений: 5
Зарегистрирован: 16 авг 2016, 18:42


Вернуться в Графические интерфейсы Астериск

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 0

© 2008 — 2019 Asterisk.ru
Digium, Asterisk and AsteriskNOW are registered trademarks of Digium, Inc.
Design and development by PostMet-Netzwerk GmbH