Чат  ::   FAQ  ::   Поиск  ::   Регистрация  ::   Вход

CISCO 7970 OVPN

Новичком считается только что прочитавший «Астериск - будущее телефонии»
http://asterisk.ru/knowledgebase/books
и пытающийся сделать большее

Модератор: april22

Re: CISCO 7970 OVPN

Сообщение Zavr2008 » 07 авг 2018, 10:49

Используем такую связку CISCO 7970 <--> Mikrotik <--OVPN--> FreePBX14
В Микротике подключено два провайдера и скрипт переключающий линию если одна недоступна.


И всё бы было хорошо если бы OVPN в микротиках был нормальный. Краеугольный камень)
Сколько прибалтов народ пилит по поводу OpneVpn UDP - а воз и ныне там.
Ставьте на второй стороне тоже микротик.
Подумать о другом туннеле каком (VPS если FreePBX) - eoip или же gre или же новомодный sstp.

Переключать WAN скриптом - дело то еще. См. лучше схему с балансировкой двух WAN одновременной - с маркировкой в Mangle. Ну а резервирование пропадания просто шлюзом вторым.
Хорошая статья на эту тему: https://habr.com/post/313342/

Также следует понять что 7970 не ходят за NAT - там четко должно быть внутри и доступно постоянно. пиры должны быть в localnet и с directmedia=no.
Может стоит в офисе где стоят 7970 поставить локальный астер для регистрации и уже этот астер связать с основным по тому же IAX2 чтобы не залипало ничего.
Последний раз редактировалось Zavr2008 07 авг 2018, 10:58, всего редактировалось 4 раз(а).
Asterisk-совместимые Российские SIP/E1 шлюзы Alvis. Для форумчан скидки ! В цены входит настройка связи с Asterisk! Помогаем в настройке TDM АТС: TDA/TDE/LDK и др.
Аватар пользователя
Zavr2008
 
Сообщений: 1180
Зарегистрирован: 27 янв 2011, 01:35

Re: CISCO 7970 OVPN

Сообщение ded » 07 авг 2018, 10:52

шедулер = scheduler [ˈʃedjuːlər]
ded
 
Сообщений: 13283
Зарегистрирован: 26 авг 2010, 19:00

Re: CISCO 7970 OVPN

Сообщение skynetyar » 07 авг 2018, 16:58

Zavr2008
Огромное спасибо за развернутый ответ!
На самом деле да, вынуждены юзать TCP из за микротика с его наболевшей проблемой OVPN=TCP, но решение было использовать именно так как все привязано уже и заниматься настройкой других вариантов было некогда,большое спасибо за варианты, обязательно изучу их!

Есть два WAN и их Distance который расставляет приоритет в WAN и собственно и служит переключением линий, более для переключений линий при обрыве ничего не используем.

По поводу scheduler и
Код: выделить все
:foreach i in=[/ip firewall connection find dst-address~":5060" protocol~"TCP"] do={ /ip firewall connection remove $i }

Реально будет работать ? Простите что спрашиваю, линия активно используется и экспериментировать особо нет возможности...

Что Вы думаете по поводу еще такого варианта с netwatch

Код: выделить все
/tool netwatch
add comment=«Check Main Link via 8.8.8.8» host=8.8.8.8 timeout=500ms /
down-script=":log warning («WAN1 DOWN»)
:foreach i in=[/ip firewall connection find dst-address~":5060"] do={
:log warning («clear-SIP-connections: clearing connection src-address:$[/ip firewall connection get $i src-address] dst-address:$[/ip firewall connection get $i dst-address]»)
/ip firewall connection remove $i}"
up-script=":log warning («WAN1 UP»)
:foreach i in=[/ip firewall connection find dst-address~":5060"] do={
:log warning («clear-SIP-connections: clearing connection src-address:$[/ip firewall connection get $i src-address] dst-address:$[/ip firewall connection get $i dst-address]»)
/ip firewall connection remove $i}"
Всё знают и всё понимают только дураки да шарлатаны.(с)А.П Чехов.
skynetyar
 
Сообщений: 352
Зарегистрирован: 18 авг 2016, 14:25

Re: CISCO 7970 OVPN

Сообщение skynetyar » 21 сен 2018, 17:27

Напомню есть несколько Gateway и они переключаются по приоритету Distance
Проблема:
При переключении Gateway телефон CISCO 7970 не пытается перерегистрироваться и как бы повисает, несмотря на то что на Asteriske они как Unavail и подключены по PJSIP
В микротик они подключены через OVPN
Сделал так:
PPP-->Новый профиль--> Scripts ---> в нем на UP и DOWN
:foreach i in=[/ip firewall connection find dst-address~":5060"] do={ /ip firewall connection remove $i }

Проверяю так , в терминале микротика делаю команду
put [/ip firewall connection find dst-address~":5060"]
Выводит значения всех найденных соединений.

Произвожу тестирование, отключаю один Gateway , таблица соединений чистится ! там пусто, на Asteriske все в Unavalible , но CISCO пофигу на все, он упорно продолжает делать вид что все в порядке! и только после того как на нем что то наберешь например номер , то он начинает уходить в register

Уже все вроде перепробовал, по идее же должно работать, почему не работает? Как заставить делать сам CISCO qualify что ле какое то?
А может KeepAlive на сервере OVPN там где Astrerisk уменьшить?
Всё знают и всё понимают только дураки да шарлатаны.(с)А.П Чехов.
skynetyar
 
Сообщений: 352
Зарегистрирован: 18 авг 2016, 14:25

Re: CISCO 7970 OVPN

Сообщение ded » 21 сен 2018, 19:09

CISCO телефону пофигу, потому что так устроен SIP протокол. Он отправляет пакет REGISTER и получает на него ответ ОК.
Далее, в течение всего времени таймера Max-Expiry он будет считать себя зарегистрированным, не важно - есть интернет, или он побежал через другой Gateway, или вообще нет интернета.
Заставьте телефон регистрироваться каждую минуту, и он будет +/- адекватно реагировать на переключение Gateway.
Раньше так делали вместо nat keepalive.
Не спрашивайте - как или где. Удочку, не рыбу.
ded
 
Сообщений: 13283
Зарегистрирован: 26 авг 2010, 19:00

Re: CISCO 7970 OVPN

Сообщение skynetyar » 26 сен 2018, 15:05

Спасибо большое за информацию!
Бил-бил Mikrotik, ни при каких обстоятельствах не смог заставить через Mikrotik перерегистрироваться CISCO, ему действительно вообще по барабану, хотя горячие головы утверждали обратное, что они с легкостью заставляют перезагружаться их..,но этот способ за 7 печатями тайны.
Так же в настройках OVPN сервера параметр KeepAlive установкой 5 10 тоже не помог..

У меня вопрос, именно заставить регистрацию производить или опрос регистрации в CISCO параметрах телефона где то?
Можно пожалуйста пруф на лекции пожалуйста?
Всё знают и всё понимают только дураки да шарлатаны.(с)А.П Чехов.
skynetyar
 
Сообщений: 352
Зарегистрирован: 18 авг 2016, 14:25

Re: CISCO 7970 OVPN

Сообщение ded » 26 сен 2018, 17:34

<sipStack>
<sipInviteRetx>6</sipInviteRetx>
<sipRetx>10</sipRetx>
<timerInviteExpires>180</timerInviteExpires>
<timerRegisterExpires>3600</timerRegisterExpires>
<timerRegisterDelta>5</timerRegisterDelta>
<timerKeepAliveExpires>120</timerKeepAliveExpires>
<timerSubscribeExpires>120</timerSubscribeExpires>
<timerSubscribeDelta>5</timerSubscribeDelta>
<timerT1>500</timerT1>
<timerT2>4000</timerT2>
<maxRedirects>70</maxRedirects>
<remotePartyID>true</remotePartyID>
<userInfo>None</userInfo>
</sipStack>

укажите вместо 3600 что-нить 10 - каждые 10 сек будет регистрироваться
ded
 
Сообщений: 13283
Зарегистрирован: 26 авг 2010, 19:00

Пред.

Вернуться в Вопросы новичков

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 15

© 2008 — 2018 Asterisk.ru
Digium, Asterisk and AsteriskNOW are registered trademarks of Digium, Inc.
Design and development by PostMet-Netzwerk GmbH