Чат  ::   FAQ  ::   Поиск  ::   Регистрация  ::   Вход

FreeSwitch и исходящие вызовы на Addpac

Использование и настройка других открытых VoIP PBX

Модератор: april22

Re: FreeSwitch и исходящие вызовы на Addpac

Сообщение Vlad1983 » 01 июн 2016, 08:45

Код: выделить все
conf t
voice class codec 0
no codec preference 3
no codec preference 4
no codec preference 5
no codec preference 6
Мобильные РФ 1.2 руб./мин. + НДС с посекундной тарификацией, CLI
Telegram: @rostel
Vlad1983
 
Сообщений: 4131
Зарегистрирован: 09 авг 2011, 11:51

Re: FreeSwitch и исходящие вызовы на Addpac

Сообщение awsswa » 01 июн 2016, 09:44

Это тоже удалите

gateway
h323-id voip.192.168.7.5
gkip 192.168.7.5 1719 128
no ignore-msg-from-other-gk
register

до состояния
gateway
h323-id voip.192.168.7.5
no ignore-msg-from-other-gk
shutdown
платный суппорт по мере возможностей
awsswa
 
Сообщений: 2306
Зарегистрирован: 09 июн 2012, 10:52
Откуда: Россия, Пермь skype: yarick_perm

Re: FreeSwitch и исходящие вызовы на Addpac

Сообщение AlexanderAvva » 01 июн 2016, 13:20

нет, это не помогло, хотя, возможно, что -то не то сделал.
Что было сделано:
GS1002# conf t
GS1002(config)# voice class codec 0
GS1002(config-vclass-codec#0)# no codec preference 3
GS1002(config-vclass-codec#0)# no codec preference 4
GS1002(config-vclass-codec#0)# no codec preference 5
GS1002(config-vclass-codec#0)# no codec preference 6
GS1002(config-vclass-codec#0)# gateway
GS1002(config-gateway)# h323-id voip.192.168.7.5
GS1002(config-gateway)# no ignore-msg-from-other-gk
GS1002(config-gateway)# shutdown
GS1002(config-gateway)#
текущий конфиг:

[Показать] Спойлер:
GS1002(config-gateway)# show running-config
Building configuration...

Current configuration:
!
version 8.51.010
!
hostname GS1002
!
username root password router administrator
username guest password guest user
username al password 1 administrator
!
!
interface Loopback0
ip address 127.0.0.1 255.0.0.0
!
interface FastEthernet0/0
ip address dhcp
no ip dhcp unicast
ip access-group 1 in
speed auto
no qos-control
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
ip access-group 1 in
speed auto
no qos-control
!
! ip route 0.0.0.0 0.0.0.0 192.168.7.1 via dhcp
!
access-list 1 permit any
!
!
!
!
http server
!
! dns name-server 192.168.7.1 via dhcp
!
!
logging command
logging event 4-warning
logging on
!
!
!
!
! VoIP configuration.
!
!
! Voice service voip configuration.
!
voice service voip
protocol sip
dtmf-relay rfc-2833
fax protocol duplex-t38 redundancy 2
fax rate 9600
h323 call start fast
h323 call channel latest
h323 call tunnel enable
timeout tinit 15
timeout tidt 5
static-jitter-buffer 35
ignore-dtmf-abcd-tone
no call-barring unconfigured-ip-address
no voip-inbound-call-barring enable
!
!
! Voice port configuration.
!
! GSM
voice-port 0/0
connection plar 9991299201
dial-tone-generate
caller-id enable
caller-id name disable
!
!
! GSM
voice-port 0/1
dial-tone-generate
no caller-id enable
!
!
! FXS
voice-port 0/2
caller-id enable
!
!
! FXS
voice-port 0/3
caller-id enable
!
!
!
!
! service port group configuration.
!
!
!
! Pots peer configuration.
!
dial-peer voice 10 pots
destination-pattern 8..........F
port 0/0
no register e164
!
!
!
! Voip peer configuration.
!
dial-peer voice 1 voip
destination-pattern 9991299201
session target ip 192.168.7.76 5080
session protocol sip
voice-class codec 0
no vad
dtmf-relay rtp-2833
no sid
!
!
!
!
dial-peer hunt 5
!
!
gatekeeper
!
!
! Gateway configuration.
!
gateway
h323-id voip.192.168.7.5
gkip 192.168.7.5 1719 128
no ignore-msg-from-other-gk
register
shutdown
!
!
! Codec classes configuration.
!
voice class codec 0
codec preference 1 g711alaw
codec preference 2 g711ulaw
!
!
!
! SIP UA configuration.
!
sip-ua
user-register
sip-username 1015
sip-password 1015
sip-server 192.168.7.76
set-local-domain 192.168.7.76
remote-party-id
register gateway
!
!
! Tones
!
!
! SMS delivery configuration
!
sms-delivery
!
!
!
!
!
line console
!
line vty
!
mobile dev-restart-by-unreg 300
mobile dev-restart-by-unknown-error
mobile cell-monitor 30
!
mobile 0/0
gsm sms-language utf8
!
mobile 0/1
gsm sms-language utf8
!
end
GS1002(config-gateway)#

возможно, нужно было

вызов с Zoiper на мобилу не идет
2016-06-01 12:13:34.210082 [WARNING] switch_core_codec.c:728 Codec PCMA Exists but not at the desired implementation. 8000hz 20ms 3ch
2016-06-01 12:13:34.210082 [ERR] switch_core_media.c:2838 Can't load codec?

я правильно понимаю, что мне нужно включить
fs_cli> sofia profile internal siptrace on
fs_cli> sofia profile external siptrace on
и приложить логи?
AlexanderAvva
 
Сообщений: 24
Зарегистрирован: 30 май 2016, 04:51

Re: FreeSwitch и исходящие вызовы на Addpac

Сообщение AlexanderAvva » 01 июн 2016, 13:27

не относящееся к кодеку (в предыдущем сообщении после "Возможно нужно было" - исчезли фразы).
Возможно нужно было дать команду в addpac no gkip, но не выдавал, т.к. не было сказано явно.
В голове какой - то сумбур по поводу того, что есть гейткипер в addpac- мне представлялось, что за обработку паттерна исходящей связи и вообще внутренней логики как раз он и отвечает, т.е. все эти
destination-pattern 8..........F
port 0/0

destination-pattern 9991299201
session target ip 192.168.7.76 5080

это как раз роль гейткипера.
Но Бог с ним - работает и ладно.
AlexanderAvva
 
Сообщений: 24
Зарегистрирован: 30 май 2016, 04:51

Re: FreeSwitch и исходящие вызовы на Addpac

Сообщение AlexanderAvva » 01 июн 2016, 13:31

Есть еще одно наблюдение: есть такой десктопный клиент FSClient. С него вызовы на мобилу проходят нормально, но с "эхом в мобиле". Т.е. именно с "наличием" кодеков все в порядке.
Сейчас буду логи снимать при вызове через Zoiper.
AlexanderAvva
 
Сообщений: 24
Зарегистрирован: 30 май 2016, 04:51

Re: FreeSwitch и исходящие вызовы на Addpac

Сообщение AlexanderAvva » 01 июн 2016, 13:38

часть 1

сообщение модератора: эта и все последующие части удалены
AlexanderAvva
 
Сообщений: 24
Зарегистрирован: 30 май 2016, 04:51

Re: FreeSwitch и исходящие вызовы на Addpac

Сообщение AlexanderAvva » 03 июн 2016, 14:28

Эксперименты с разными sip android клиентами привели к выводу, что лучше всего с addpac работает клиент Zadarma. По крайней мере удается сделать через sip софтофон с андроида вызов через addpac и поговорить. Остальные android клиенты либо сразу выдают ошибку несовместимого кодека, либо позволяют прозвониться, но ничего не слышно. Причем настройка последовательности используемых кодеков слабо влияет на ситуацию.
Только, похоже, что связь мобильный-freeswitch-addpac-мобильный рвется через 1-2 минуты, куда рекомендуете посмотреть, и, насколько это распространенная ошибка?
aggressive-nat-detected стоит в конфиге freeswitch, android c sip клиентом в той же подсети, что и freeswitch (так что вряд-ли nat).
AlexanderAvva
 
Сообщений: 24
Зарегистрирован: 30 май 2016, 04:51

Re: FreeSwitch и исходящие вызовы на Addpac

Сообщение Vlad1983 » 03 июн 2016, 15:14

что вы этими логами показать хотели?
нет ни единой попытки вызова через шлюз
Мобильные РФ 1.2 руб./мин. + НДС с посекундной тарификацией, CLI
Telegram: @rostel
Vlad1983
 
Сообщений: 4131
Зарегистрирован: 09 авг 2011, 11:51

Re: FreeSwitch и исходящие вызовы на Addpac

Сообщение AlexanderAvva » 04 июн 2016, 01:56

Влад, извините, не умею, видимо снимать логи правильно.
Худо-бедно с помощью клиента Zadarma - проблема, как-будто отошла на второй план.
Возникла при тестировании новая проблема: стабильный обрыв исходящего соединения (входящее нормально).
Как проходит соединение:
Мобила->Dect трубка, подключенная к Zyxel router c FXS->FS->Addpac->Клиент мобильника
При исходящей связи через 2 минуты обрыв связи.
В логах роутера в это время следующее:

13 06/04/2016 00:02:57 SIP Response Error :method:INVITE Rsp code:480
14 06/04/2016 00:02:56 Error, Call fail: RTP connect fail RTP
15 06/04/2016 00:01:56 Error, Call fail: RTP connect fail RTP
16 06/04/2016 00:00:56 VoIP Call Start Ph[1] -> 89Номер мобилы VOIP-FSM
Роутер P-2302HWUDL-P1, включен режим Enable Network Address Translation, выключено все, что связано с ALG.
FS с addpac стоят в одной сети, в FS поставлен режим aggressive-nat.

Порекомендуйте, если не сложно, в какую сторону смотреть?
Я так понимаю, что RTP это как раз то, что передает голос и он поверх UDP, т.е. проблемы могут быть именно в сети, или же что - то пробовать менять в настройках FS?
В конфиге FS есть параметры:
<param name="ext-sip-ip" value="auto-nat"/>

<!-- rtp inactivity timeout -->
<param name="rtp-timeout-sec" value="300"/>
<param name="rtp-hold-timeout-sec" value="1800"/>
имеет смысл играться параметрами, связанными с rtp, смотреть сеть, или же дело может быть в чем-то другом?
AlexanderAvva
 
Сообщений: 24
Зарегистрирован: 30 май 2016, 04:51

Re: FreeSwitch и исходящие вызовы на Addpac

Сообщение AlexanderAvva » 04 июн 2016, 02:06

нашел в интернте описание аналогичной проблемы в http://www.xdsl.ru/svpro/viewtopic.php?f=4&t=3815, там грешили на прошивку addpac: у меня как раз та самая прошивка gs1002_g2_v8_51_010.bin: может быть в этом дело? Если да, то где можно взять ту, о которой пишут в указанной ссылке? Симптомы только в обрыве исходящей связи, в логах addpac время звонка определяется корректно.
AlexanderAvva
 
Сообщений: 24
Зарегистрирован: 30 май 2016, 04:51

Пред.След.

Вернуться в FreeSwitch, SER, Yate и другие

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

© 2008 — 2018 Asterisk.ru
Digium, Asterisk and AsteriskNOW are registered trademarks of Digium, Inc.
Design and development by PostMet-Netzwerk GmbH