ВидеоКонф(ВКС)  ::   FAQ  ::   Поиск  ::   Регистрация  ::   Вход

На какой версии Linux сейчас собирать Астериск

Общие вопросы по операционной системе

Модераторы: april22, Zavr2008

На каком Линуксе вы бы сейчас собирали Астериск:

- Centos Stream
0
Голосов нет
- Ubuntu
0
Голосов нет
- Debian
1
100%
- Red Hat Ent
0
Голосов нет
- Fedora
0
Голосов нет
- Oracle Linux
0
Голосов нет
- AlmaLinux
0
Голосов нет
- Rocky Linux
0
Голосов нет
- Centos 7
0
Голосов нет
- Centos 8
0
Голосов нет
 
Всего голосов : 1

На какой версии Linux сейчас собирать Астериск

Сообщение Vadimov » 05 фев 2023, 14:55

Добрый день. Думаю пересадить свой Астер с древней Centos 6 на что-то более свежее. Посему встал вопрос: на что?

Классическая Centos, как вы, наверное, знаете приказала долго жить, реинкарнировавшись в вечную beta-версию Centos Stream и, вдобавок, форкнула сразу на несколько веток от бывших разрабов: AlmaLinux, Rocky Linux..

Помимо них есть еще платная Red Hat Ent, супер популярная нынче Ubuntu, великая и могучая Debian, вечный конкурент RHLS - Oracle Linux. Ну превратившиеся в "хромых уток" Centos 7 и 8.

Короче, глаза разбегаются, будь они неладны. Я сделал экспресс- анализ популярности в Гугле запроса Asterisk + Название ОС и вот что получил:
- Centos - 59 млн. запросов
- Red Hat - 3 млн. запросов
- Ubuntu - 2.5 млн. запросов
- Oracle Linux - 1.3 млн. запросов
- Debian с Fedora - по 0.9 млн. запросов
- Centos Stream - 0.6 млн. запросов

Сам склоняюсь к Oracle Linux или Debian, а что выбрали бы вы?
Vadimov
 
Сообщений: 14
Зарегистрирован: 04 сен 2013, 12:26

Re: На какой версии Linux сейчас собирать Астериск

Сообщение ded » 05 фев 2023, 16:31

Мы форкнули FreePBX в свой дистр - MetPBX, взяв за основу Debian, в память трудов Деборы и невинно убиенного Яна.
Если не экпериментировать, не пытаться из старой тумбочки сделать современный комод, не добавлять модную обвеску, то можно поддерживать в работе даже очень древние вещи. У клиентов работают древнейшие FreePBX с Астериск 1.8, и, по принципу - работает? Не трожь! - уже более 10 лет всё ОК.
А на современную версию, для работы - собирать не надо. Взять примелемый не очень новый дистр ОС, и выполнить там
apt install asterisk
dnf install asterisk
yum install asterisk
zypper install asterisk
для чистой рабочей инсталляции. Чтобы иметь юзабельную оболочку - приходится уже сильно повозиться.
ded
 
Сообщений: 15818
Зарегистрирован: 26 авг 2010, 19:00

Re: На какой версии Linux сейчас собирать Астериск

Сообщение Vadimov » 24 фев 2023, 16:53

Не спорю, сам просидел более 10 лет на Centos 6 и сидеть продолжаю. Все устраивает и прекрасно работает, но.. Любая попытка что-то добавить, при неработающем менеджере пакетов, превращается в большую проблему.

Недавно, например, решил добавить в систему 3g модем и так и не смог, поскольку тупо не смог установить modeswitch. Хотя времени на это потратил изрядно.
Vadimov
 
Сообщений: 14
Зарегистрирован: 04 сен 2013, 12:26

Re: На какой версии Linux сейчас собирать Астериск

Сообщение ded » 24 фев 2023, 17:50

Примерно тем же занимаюсь сейчас, на Red Hat Enterprise Linux release 8.2 (Ootpa), но не связано с Астериск.
Попытка поставить новый open source софт потянула такую невыполнимую кучу!
MariaDb => galera-4, php82, php82-php-fpm, и так далее. И просто какой-то армрестлинг -
Name Information Report Plugin Status
database mariadb (5.5.5-10.3.17-MariaDB)
version 10.6.7 is required and you are running 10.3.17
Check
php
version 8.0.0 is required and you are running 7.4.33
Check
unicode
must be installed and enabled
OK
pcreunicode
should be installed and enabled for best results
OK
php_extension iconv
must be installed and enabled
OK
php_extension mbstring
must be installed and enabled
OK
php_extension curl
must be installed and enabled
OK
php_extension openssl
must be installed and enabled
OK
php_extension tokenizer
should be installed and enabled for best results
OK
php_extension soap
should be installed and enabled for best results
OK
php_extension ctype
must be installed and enabled
OK
php_extension zip
must be installed and enabled
OK
php_extension zlib
must be installed and enabled
OK
php_extension gd
must be installed and enabled
OK
php_extension simplexml
must be installed and enabled
OK
php_extension spl
must be installed and enabled
OK
php_extension pcre
must be installed and enabled
OK
php_extension dom
must be installed and enabled
OK
php_extension xml
must be installed and enabled
OK
php_extension xmlreader
must be installed and enabled
OK
php_extension intl
must be installed and enabled
OK
php_extension json
must be installed and enabled
OK
php_extension hash
must be installed and enabled
OK
php_extension fileinfo
must be installed and enabled
OK
php_extension sodium
must be installed and enabled
OK
php_extension exif
should be installed and enabled for best results
OK
php_setting memory_limit
recommended setting detected
OK
php_setting file_uploads
recommended setting detected
OK
php_setting opcache.enable
recommended setting detected
OK
ded
 
Сообщений: 15818
Зарегистрирован: 26 авг 2010, 19:00


Вернуться в Linux

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2

© 2008 — 2024 Asterisk.ru
Digium, Asterisk and AsteriskNOW are registered trademarks of Digium, Inc.
Design and development by PostMet-Netzwerk GmbH